Forcer l'utilisation de PHP5 dans le cadre d'un hébergement mutualisé

Publié le par Steeve BOIS

Salut toi!
Bon voilà un petit cas pratique : disons que tu souhaites lancer ton propre site Internet et que tu  n'as pas forcément les moyens.

Tu aimerais dans l'idéal disposer d'un serveur dédié sur lequel tu installerais et désinstallerais ce que tu veux mais voilà tu te dis "je suis pas Arthus-Bertrand.....heu Crésus... :D"

Alors voilà, tu optes pour un hébergement mutualisé.
Maintenant tu upload ton site web (tu as opté pour Joomla par ex. ou bien DotClear) et en testant ton adresse tu te rend compte que le résultat n'est pas du tout à la mesure de tes attentes!

Rien ne s'affiche correctement et en surfant sur le net on te dis "oui heu il faut forcé l'utilisation de PHP5".
Alors oui la solution dans ce cas est la suivante :

  • Créer un fichier que tu appellera ".htaccess"
  • Tu ouvres ton fichier avec un éditeur de texte digne de ce nom genre Ultra Edit, MEMAC, EMAC, LaTex...
  • Tu y insert le code suivant :

                AddHandler x-httpd-php5 .php

                AddType application/x-httpd-php5 .php

Tu sauvegardes le tout et tu le mets à la racine de ton site web.
Et là, merveille, ton site fonctionne correctement et te voilà tranquille pour continuer son développement ou son administration sans plus jamais te prendre la tête avec ce genre de souci qui peuvent sembler insurmontable.


Fais tourner!

Publié dans Programmation

Commenter cet article

Vincent Gruyer, panographie 16/02/2008 20:55

merci pour ta vidéo